Verification is currently underway for the maintenance items.
Posted Nov 06, 2024 - 12:20 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 06, 2024 - 12:00 CET
Scheduled
On Wednesday 6th of November from 12am to 1pm, we will perform an infrastructure update on preview environment that will cause small downtime (around 5 minutes).
Please let us know if you need more information.
Posted Nov 05, 2024 - 16:35 CET
This scheduled maintenance affected: TrustBuilder.io Preview.